Orders Release
Incident Report for DriveWealth
Resolved
This incident has been resolved.
Posted Jan 17, 2023 - 18:59 EST
Monitoring
Dear Valued Partner,
This morning we experienced a pre-market trading issue which caused latency in orders being released to the market. All impacted orders were pre-market, and therefore DriveWealth will adjust any negatively impacted orders, due to the latency, to the opening price. Please note that only orders placed after 4:30pm ET January 13, 2023 and before 9:28am ET January 17, 2023 may have been impacted.
Our engineers have diagnosed a root cause and we will be distributing an analysis as soon as possible.
Please contact your PSG Account Manager if you have any concerns.
Posted Jan 17, 2023 - 15:43 EST
Investigating
We are currently experiencing an issue with orders that arrived over this past weekend, January 14, 15, 16th, 2023. At this time, some of these orders have not been filled. Please note we are not experiencing any issues for orders received from 9:30am EST today, January 17th, 2023. We have a team of engineers currently working on this and we will provide an update as soon as possible.
Posted Jan 17, 2023 - 10:00 EST