Post Trade
Incident Report for DriveWealth
Resolved
he previously reported Post Trade issue has been resolved. All systems are currently operational. Trading was not impacted by this issue.
Posted Nov 10, 2023 - 09:19 EST
Update
We continue to investigate the Post Trade issue. More information will follow.
Posted Nov 10, 2023 - 08:44 EST
Investigating
DriveWealth is currently experiencing a Post Trade issue Our team is investigating to determine the cause and a plan of action to rectify this. We will keep you updated with our progress.
Should you have any affected accounts, your Account Consultant will reach out to you with more information.
Posted Nov 10, 2023 - 08:13 EST