As part of our remediation efforts, the DriveWealth team has regenerated a file containing the impacted orders with the correct order fill quantities and prices. This updated file has been provided to the affected partners. if you have any remaining questions or concerns, please reach out to your Partner Support Team.
Posted Oct 21, 2025 - 14:57 EDT
Investigating
Please be advised that DriveWealth is currently investigating a technical issue affecting a subset of executions, resulting in discrepancies in the displayed order quantity and price sent in files provided to you by our Partner Support team and DriveHub for execution from October 20, 2025. We confirmed that individual order fill quantity and pricing remain accurate within DriveHub. Our engineering teams are actively working to identify all impacted order fills and will provide updates as more information becomes available. Please note that all systems are restored for today's trading day. We will continue our clean up remediation efforts for trade date 10/20/2025 and will keep you apprised of updates. If you have any questions or need assistance, please contact the Partner Support Team.
Posted Oct 21, 2025 - 08:54 EDT
Monitoring
While AWS functionality has stabilized, DriveWealth continues to assess the full scope of today’s events. At this time, we expect normal processing to resume tomorrow, Tuesday, October 21st, 2025. We will continue to provide updates as more information emerges. If you have any questions, please reach out to the Partner Support team.
Posted Oct 20, 2025 - 18:59 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 18:59 EDT
Update
We are currently investigating a technical issue affecting the displayed execution price in SQS notification messages for a subset of API orders placed around Market Open. Please note that the issue did not impact the actual execution price of the orders. However, the displayed execution price in the SQS notification messages may have been different from the actual execution price for certain API orders placed around Market Open. Our engineering teams are actively working to identify the list of impacted orders, determine the root cause, and implement a resolution as quickly as possible. We will continue to provide updates as more information becomes available, and a full Root Cause Analysis (RCA) will be provided once the investigation is complete.
Posted Oct 20, 2025 - 15:40 EDT
Update
Please be advised that DriveWealth is currently investigating additional technical issues impacting API processing, errors and latency, which are related to ongoing service degradation reported by AWS. Our engineering team is actively working to assess the full scope of the impact and will share further details as they become available. We will continue to provide updates as more information emerges. If you have any questions, please contact the Partner Support team.
Posted Oct 20, 2025 - 13:25 EDT
Identified
We have resolved the previously identified technical issue affecting the timely delivery of a subset of partner order executions. The delay was caused by ongoing AWS network connectivity issues in the US-EAST-1 region. Our engineering teams have addressed the root cause, and all delayed order executions have now been processed. Normal service has been restored. If you continue to experience any issues with order execution delivery, please contact the Partner Support team. The DriveWealth engineering team is actively assessing the situation, working to mitigate any remaining impacts, and monitoring AWS updates.
Posted Oct 20, 2025 - 11:23 EDT
Investigating
We are actively investigating an issue that is currently affecting API processing. The issue appears to be caused by a recurrence of the earlier AWS incident affecting multiple services (https://health.aws.amazon.com/health/status). Our teams are working to mitigate the issue and will continue to monitor for further developments. Our engineering teams are actively working to assess the full scope of the impact and are awaiting additional updates from AWS, expected within the next 30–45 minutes. We will provide the next update by 11:00 AM ET, or sooner if new information becomes available. We appreciate your patience and understanding as we work to resolve this matter. For any questions, please contact the Partner Support team.