Delays Reporting Certain Opening Execution Messages
Incident Report for DriveWealth
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 10:31 EDT
Update
DriveWealth is continuing to investigate and will reach out individually affected partners.
Posted Mar 18, 2024 - 12:01 EDT
Update
DriveWealth continues to investigate and monitor.
Posted Mar 18, 2024 - 11:28 EDT
Update
DriveWealth continues to investigate and monitor.
Posted Mar 18, 2024 - 10:58 EDT
Update
DriveWealth continues to investigate and monitor.
Posted Mar 18, 2024 - 10:58 EDT
Monitoring
All affected execution reports were delivered to customers as of 10:17 AM EDT. DriveWealth continues to monitor executions reported by the liquidity partner.
Posted Mar 18, 2024 - 10:28 EDT
Investigating
Due to a technical issue at one of DriveWealth's liquidity partners, DriveWealth experienced delays reporting a limited number of opening execution trade reports to certain partners. All effected execution reports were delivered as of 10:17 AM EDT. DriveWealth will contact individually impacted partners
Posted Mar 18, 2024 - 10:25 EDT