DTCC/NSCC Settlement Disruption — Market-Wide Event(June 29, 2026)

Incident Report for DriveWealth

Resolved

We have been working closely with DTCC throughout today's Market Disruption Event and expect all NSCC and DTC settlement activity to proceed as standard. Our systems remain fully operational and were not impacted at any point during this event.
Posted Jun 30, 2026 - 16:28 EDT

Monitoring

We are aware of DTCC's statement declaring a Market Disruption Event under DTCC rules. DTCC has implemented a full rollover of NSCC and DTC settlement for June 29, 2026, resulting in a double settlement day on June 30, 2026. This was caused by erroneous trades submitted by another member firm. This is a Street-wide issue affecting the industry broadly. Today's trading activity is not impacted by this issue, and our systems continue to operate normally. We are working closely with DTCC to monitor the situation and will share additional information as it becomes available.
Posted Jun 30, 2026 - 08:48 EDT