Issue with tickers BBD and BBDO
Incident Report for DriveWealth
Resolved
DriveWealth has resolved the issue and remediated the affected accounts. If you have any immediate questions, please contact your PSG Account Manager.
Posted May 25, 2022 - 17:57 EDT
Update
DriveWealth has identified the issue and we are working to remediate the affected accounts. At this time, the tickers BBD and BBDO have been made active and will be available for trading on Monday May 2, 2022 at the open. We encourage you to monitor these updates as we work towards resolution.
Posted Apr 29, 2022 - 17:13 EDT
Identified
DriveWealth is currently experiencing an issue with tickers BBD and BBDO. This may be affecting your customers positions and any trades for these symbols. The symbols have been set to inactive while we determine the cause and plan of action to rectify this concern. We will keep you updated on our progress.

If you have any immediate questions, please contact your PSG Account Manager.
Posted Apr 29, 2022 - 13:03 EDT