Orders at Today's Open
Incident Report for DriveWealth
Resolved
Please be advised that this incident has been resolved as of market close 7/20/23 and all impacted orders have been identified. Your relationship management team will be contacting you directly to advise on any impacted orders
Posted Jul 21, 2023 - 12:22 EDT
Update
Please be advised that orders should now be flowing as expected. We are continuing to review to determine impact. Your PSG Account Management team will be able to provide more information shortly.
Posted Jul 21, 2023 - 07:29 EDT
Monitoring
Please be advised that orders should now be flowing as expected. We are continuing to monitor and review to determine impact. We will provide more information as it becomes available.
Posted Jul 20, 2023 - 17:27 EDT
Identified
Please be advised that although we have identified the root cause and are working towards remediating, there may continue to be new orders affected which are not being released. We are continuing to work to remediate and will provide more information as it becomes available.
Posted Jul 20, 2023 - 14:56 EDT
Update
Please be advised that along with a number of orders at the open not being released, we also have identified that currently there are a number of new orders that are not being released. We are continuing to investigate and will provide more information as it becomes available.
Posted Jul 20, 2023 - 12:58 EDT
Investigating
Please be advised that a number of orders were not released at the open today, Thursday 7/20/23. We are currently investigating to identify the root cause and will provide more information as it becomes available.
Posted Jul 20, 2023 - 12:23 EDT