KYC Processing Delay
Incident Report for DriveWealth
Resolved
The previously reported issue has been resolved. All systems are operating normally.
Posted Apr 17, 2024 - 12:51 EDT
Identified
DriveWealth is currently investigating a technical issue that may result in KYC processing and account opening delays. Our team will provide additional information as soon as possible.
Posted Apr 17, 2024 - 11:52 EDT